2018 Update Rollup 2

Supported Platforms and System RequirementsPermanent link for this heading

Fabasoft app.telemetry AgentPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry agents are supported on the following platforms:

Operating System

Architecture

Microsoft Windows Server 2008 R2 SP1

x64

Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2

x64

Microsoft Windows Server 2016

x64

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

x64

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

x64

System RequirementsPermanent link for this heading

Fabasoft app.telemetry agents have the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:50 MB
  • Memory:100 MB

Software-Telemetry caching or intense check definitions impact those system requirements and might cause appropriate adaptations.

PrerequisitesPermanent link for this heading

Fabasoft app.telemetry agents have the following prerequisites:

Operating System

Prerequisite

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

RPM curl 7.19.7
RPM net-snmp 5.5
RPM net-snmp-libs 5.5
RPM libxml2 2.7.6
RPM openssl 1.0.1

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

RPM curl 7.29.0
RPM net-snmp 5.7.2
RPM net-snmp-libs 5.7.2
RPM libxml2 2.9.1
RPM openssl 1.0.1
RPM systemd 219
RPM apptelemetry-libs
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1


Fabasoft app.telemetry WebAPIPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry WebAPI is supported on the following platforms:

Operating System

Architecture

Microsoft Windows Server 2008 R2 SP1

x64

Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2

x64

Microsoft windows Server 2016

x64

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

x64

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

x64

System RequirementsPermanent link for this heading

Fabasoft app.telemetry WebAPI has the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:20 MB
  • Memory:100 MB

Software-Telemetry caching impacts those system requirements and might cause appropriate adaptations.

PrerequisitesPermanent link for this heading

Fabasoft app.telemetry WebAPI has the following prerequisites

Operating System

Prerequisite

Microsoft Windows Server 2008 R2 SP1

Microsoft Internet Information Services 7.5

Microsoft Windows Server 2012

Microsoft Internet Information Services 8.0

Microsoft Windows Server 2012 R2

Microsoft Internet Information Services 8.5

Microsoft Windows Server 2016

Microsoft Internet Information Services 10.0

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

RPM curl 7.19.7
RPM httpd 2.2.15
RPM apr 1.3.9
RPM apr-util 1.3.9

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

RPM curl 7.29.0
RPM httpd 2.4.6
RPM apr 1.4.8
RPM apr-util 1.5.2
RPM systemd 219
RPM apptelemetryagent
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1

Fabasoft app.telemetry ServerPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry servers are supported on the following platforms:

Operating System

Architecture

Microsoft Windows Server 2016

x64

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

x64

System RequirementsPermanent link for this heading

Fabasoft app.telemetry servers have the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:2 GB
  • Memory:1 GB

Software-Telemetry caching, implicit and/or explicit Software-Telemetry sessions intense check definitions impact those system requirements and might cause appropriate adaptations.

PrerequisitesPermanent link for this heading

Fabasoft app.telemetry servers have the following prerequisites:

Operating System

Prerequisite

Microsoft Windows Server 2016

Microsoft Internet Information Services 10 including the following security role services:
Basic Authentication, Windows Authentication, IP and Domain Restriction, Request Filtering and URL Authorization

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

RPM httpd 2.4.6
RPM apr 1.4.8
RPM apr-util 1.5.2
RPM net-snmp 5.7.2
RPM net-snmp-libs 5.7.2
RPM postgresql-libs 9.2.7
RPM libxml2 2.9.1
RPM minizip 1.2.7
RPM xmlsec1 1.2.20
RPM xmlsec1-openssl 1.2.20
RPM openssl 1.0.1
RPM systemd 219
RPM apptelemetryagent
APM apptelemetryweb
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1

Supported Database SystemsPermanent link for this heading

Fabasoft app.telemetry server supports the following relational database systems to store Software-Telemetry request information:

Fabasoft app.telemetry Server Operating System

Database System

Microsoft Windows Server 2016

Microsoft SQL Server 2016

PostgreSQL 9.6

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

PostgreSQL 9.2

Fabasoft app.telemetry ClientPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry clients are supported on the following platforms and web browsers:

Operating System

Architecture

Web Browser

Microsoft Windows 7 SP1

x86 and x64

Mozilla Firefox 61
Microsoft Internet Explorer 11
Google Chrome 68

Microsoft Windows 8.1

x86 and x64

Mozilla Firefox 61
Microsoft Internet Explorer 11
Google Chrome 68

Microsoft Windows 10

x64

Mozilla Firefox 61
Microsoft Internet Explorer 11
Google Chrome 68

System RequirementsPermanent link for this heading

Fabasoft app.telemetry clients have the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:100 MB
  • Memory:512 MB

Software-Telemetry analysis, intense check definitions, dashboards or large infrastructure definitions impact those system requirements and might cause appropriate adaptations.

Fabasoft app.telemetry IntegrationPermanent link for this heading

The Fabasoft app.telemetry integration (Software-Telemetry SDK) is only supported on a Fabasoft app.telemetry agent platform. For a list of supported agent platforms see chapter Supported Platforms.

Fabasoft app.telemetry Integration for C++, C#, JavaPermanent link for this heading

Fabasoft app.telemetry integration for C++, C# and Java is supported on the following platforms and interfaces:

Operating System

Environment

Microsoft Windows Server 2008 R2 SP1

Microsoft Visual Studio 2017 (C++)
Microsoft Visual Studio 2017 (C#)
Oracle Java Development Kit (JDK) 8

Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2

Microsoft Visual Studio 2017 (C++)
Microsoft Visual Studio 2017 (C#)
Oracle Java Development Kit (JDK) 8

Microsoft Windows Server 2016

Microsoft Visual Studio 2017 (C++)
Microsoft Visual Studio 2017 (C#)
Oracle Java Development Kit (JDK) 8

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

gcc 4.4.7 (C++)
Oracle Java Development Kit (JDK) 8

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

gcc 4.8.3 (C++)
Oracle Java Development Kit (JDK) 8

Fabasoft app.telemetry Integration for Java ScriptPermanent link for this heading

Fabasoft app.telemetry integration for Java Script supports the Java Script interfaces with the listed features of the following web browsers:

Supported Web Browser

JavaScript SDK

Feedback Dialogs

HTML5 Screenshot

Navigation Timing

Microsoft Internet Explorer 7 – 8

Yes

-

-

-

Microsoft Internet Explorer 9 – 11

Yes

Yes

Yes

Yes

Mozilla Firefox 61

Yes

Yes

Yes

Yes

Google Chrome 68

Yes

Yes

Yes

Yes

Fabasoft app.telemetry Integration for SyslogPermanent link for this heading

Fabasoft app.telemetry integration for Syslog is only available on Linux for “rsyslog” and supports the following platforms:

Operating System

Prerequisite

Red Hat Enterprise Linux 6.5 – 6.10,
Community ENTerprise Operating System 6.5 – 6.10

RPM rsyslog 5.8.10

Red Hat Enterprise Linux 7.4 – 7.5,
Community ENTerprise Operating System 7.4 – 7.5

RPM rsyslog 7.4.7
RPM apptelemetryagent
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1

Fabasoft app.telemetry Support MatrixPermanent link for this heading

The following support matrix lists the major features of the Fabasoft app.telemetry Integration (Software-Telemetry SDK) with the initial product version, when the feature was introduced and support starts:

Fabasoft app.telemetry SDK Features

Introduced/Supported with Product Version

Base SDK

Fabasoft app.telemetry 2008

Software-Telemetry sessions

Fabasoft app.telemetry 2008

Online Software-Telemetry logs,
reported sessions

Fabasoft app.telemetry 2009

JavaScript SDK /
End-2-End Software-Telemetry

Fabasoft app.telemetry 2009 Summer Release

Feedback button

Fabasoft app.telemetry 2010 Spring Release

Feedback button with screenshot

Fabasoft app.telemetry 2010 Summer Release

SDK for Android (Java) and Apple iOS

Fabasoft app.telemetry 2013 Winter Release

Feedback dialog screenshot preview with editing features

Fabasoft app.telemetry 2013 Summer Release

Designed on-premise forms usable as replacement for SDK report dialog – resources loaded via WebAPI

Fabasoft app.telemetry 2013 Fall Release

Multi-Language feedback forms

Fabasoft app.telemetry 2014 Winter Release

Speedtest jQuery control

JavaScript API loads CSS-images via WebAPI

Fabasoft app.telemetry 2014 Spring Release

Customizable event displayname mapping via module_registration.xml package file

Fabasoft app.telemetry 2014 Summer Release

Improved SDK for Android (Java) and Apple iOS

Fabasoft app.telemetry 2015

This version (current) of Fabasoft app.telemetry SDK is only supported on the defined Fabasoft app.telemetry agent platforms (see chapter Supported Platforms).

Fabasoft app.telemetry SNMP AgentPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry SNMP agents are supported on the following platforms:

Operating System

Architecture

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

x64

System RequirementsPermanent link for this heading

Fabasoft app.telemetry SNMP agents have the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:100 MB
  • Memory:100 MB

Larger Fabasoft app.telemetry instances impact those system requirements and might cause appropriate adaptations.

PrerequisitesPermanent link for this heading

Fabasoft app.telemetry SNMP agents have the following prerequisites:

Operating System

Prerequisite

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

RPM net-snmp-libs 5.7.2
RPM net-snmp-agent-libs 5.7.2
RPM openssl 1.0.1
RPM systemd 219
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1

Fabasoft app.telemetry Proxy ServerPermanent link for this heading

Supported PlatformsPermanent link for this heading

Fabasoft app.telemetry Proxy Servers are supported on the following platforms:

Operating System

Architecture

Microsoft Windows Server 2016

x64

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

x64

System RequirementsPermanent link for this heading

Fabasoft app.telemetry Proxy Servers have the following minimum system requirements for exclusive use:

  • CPU:1 GHz
  • Hard disk:100 MB
  • Memory:1 GB

Larger Fabasoft app.telemetry instances impact those system requirements and might cause appropriate adaptations.

PrerequisitesPermanent link for this heading

Fabasoft app.telemetry Proxy Servers have the following prerequisites:

Operating System

Prerequisite

Microsoft Windows Server 2016

Fabasoft app.telemetry Server >= 16.2

Red Hat Enterprise Linux 7.5,
Community ENTerprise Operating System 7.5

RPM apptelemetryagent >= 16.2
RPM apptelemetryserver >= 16.2
RPM openssl 1.0.1
RPM systemd 219
RPM checkpolicy 2.5
RPM policycoreutils-python 2.5
RPM selinux-policy-targeted 3.13.1

Additional ConditionsPermanent link for this heading

The installation of Fabasoft app.telemetry services in a heterogeneous operating system environment is supported as long as each Fabasoft app.telemetry service is installed on a supported platform.

The installation of Fabasoft app.telemetry services of different versions on a single computer is not supported.

The installation of Fabasoft app.telemetry services of different versions within one Fabasoft app.telemetry installation is not supported.

Fabasoft app.telemetry agents can connect to one Fabasoft app.telemetry server only.

The documented system requirements (processor, free memory and free hard disk) are minimum requirements for a demo environment or a small installation.

The supported platforms, system requirements and software prerequisites for any future version of this product may differ from current ones of this version.

A certain version of a third-party product integrated into any Fabasoft app.telemetry software product is supported by Fabasoft R&D GmbH as long as the software product itself is supported by the third-party itself. For instance a particular version of an integrated Microsoft software product is only supported by Fabasoft R&D GmbH until the date on which the Microsoft “Extended Support Phase” for this product version ends.

Third-party products that are required or supported by Fabasoft app.telemetry products, proper licensing and installation of them, necessary tests for product release as well as corresponding manufacturer support are not included in the scope of supply and services and therefore they are not subject to warranty of Fabasoft R&D GmbH regarding functionality, mode of operation or features. Fabasoft R&D GmbH is not responsible for errors or malfunction, which are caused by third-party software products and/or products that are not included in the scope of supply and services.